summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-08-11 22:57:29 +0000
committerAron Griffis <agriffis@gentoo.org>2005-08-11 22:57:29 +0000
commit57771c45e7a521e40b001011965e72240d0d2c46 (patch)
tree31a03a1acdbe3811b324b6656ec7d8766c57943c
parentremove old ebuilds (diff)
downloadgentoo-2-57771c45e7a521e40b001011965e72240d0d2c46.tar.gz
gentoo-2-57771c45e7a521e40b001011965e72240d0d2c46.tar.bz2
gentoo-2-57771c45e7a521e40b001011965e72240d0d2c46.zip
Move imap warning to pkg_setup. Mention quick start guide in pkg_postinst
#77315 (Portage version: 2.0.51.22-r2)
-rw-r--r--mail-client/mutt/ChangeLog7
-rw-r--r--mail-client/mutt/mutt-1.4.2.1.ebuild9
-rw-r--r--mail-client/mutt/mutt-1.5.8-r1.ebuild18
-rw-r--r--mail-client/mutt/mutt-1.5.8-r2.ebuild18
-rw-r--r--mail-client/mutt/mutt-1.5.9.ebuild18
5 files changed, 62 insertions, 8 deletions
diff --git a/mail-client/mutt/ChangeLog b/mail-client/mutt/ChangeLog
index 05bb282cc02a..189478e470ca 100644
--- a/mail-client/mutt/ChangeLog
+++ b/mail-client/mutt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/mutt
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.51 2005/08/11 22:48:36 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.52 2005/08/11 22:57:29 agriffis Exp $
+
+ 11 Aug 2005; Aron Griffis <agriffis@gentoo.org> mutt-1.4.2.1.ebuild,
+ mutt-1.5.8-r1.ebuild, mutt-1.5.8-r2.ebuild, mutt-1.5.9.ebuild:
+ Move imap warning to pkg_setup. Mention quick start guide in pkg_postinst
+ #77315
*mutt-1.5.9 (11 Aug 2005)
diff --git a/mail-client/mutt/mutt-1.4.2.1.ebuild b/mail-client/mutt/mutt-1.4.2.1.ebuild
index 206157ce5de8..2ca0d000ac16 100644
--- a/mail-client/mutt/mutt-1.4.2.1.ebuild
+++ b/mail-client/mutt/mutt-1.4.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.4.2.1.ebuild,v 1.7 2005/01/01 11:58:30 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.4.2.1.ebuild,v 1.8 2005/08/11 22:57:29 agriffis Exp $
IUSE="cjk imap mbox nls slang ssl vanilla"
@@ -32,7 +32,6 @@ KEYWORDS="x86 ppc sparc alpha hppa ~mips"
pkg_setup() {
if ! use imap; then
echo
- einfo
einfo "NOTE: The USE variable 'imap' is not in your USE flags."
einfo "For imap support in mutt, you will need to restart the build with USE=imap"
echo
@@ -116,6 +115,8 @@ src_install () {
}
pkg_postinst() {
- einfo "The USE variable 'imap' is not set by default on most architectures."
- einfo "To enable imap support in mutt, make sure you have USE=imap"
+ echo
+ einfo "For information about using mutt, please refer to:"
+ einfo " http://www.gentoo.org/doc/en/guide-to-mutt.xml"
+ echo
}
diff --git a/mail-client/mutt/mutt-1.5.8-r1.ebuild b/mail-client/mutt/mutt-1.5.8-r1.ebuild
index d852e64fc071..a3feb8497f00 100644
--- a/mail-client/mutt/mutt-1.5.8-r1.ebuild
+++ b/mail-client/mutt/mutt-1.5.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.8-r1.ebuild,v 1.10 2005/04/29 00:16:17 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.8-r1.ebuild,v 1.11 2005/08/11 22:57:29 agriffis Exp $
inherit eutils flag-o-matic
IUSE="cjk ssl nls slang crypt imap mbox nntp sasl vanilla"
@@ -42,6 +42,15 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc-macos ppc64 sparc x86"
+pkg_setup() {
+ if ! use imap; then
+ echo
+ einfo "NOTE: The USE variable 'imap' is not in your USE flags."
+ einfo "For imap support in mutt, you will need to restart the build with USE=imap"
+ echo
+ fi
+}
+
src_unpack() {
unpack ${P}i.tar.gz && cd ${S} || die "unpack failed"
if ! use vanilla; then
@@ -139,3 +148,10 @@ src_install() {
dodoc BEWARE COPYRIGHT ChangeLog NEWS OPS* PATCHES README* TODO VERSION
}
+
+pkg_postinst() {
+ echo
+ einfo "For information about using mutt, please refer to:"
+ einfo " http://www.gentoo.org/doc/en/guide-to-mutt.xml"
+ echo
+}
diff --git a/mail-client/mutt/mutt-1.5.8-r2.ebuild b/mail-client/mutt/mutt-1.5.8-r2.ebuild
index d7e117b5770f..a6ce1e70fe6b 100644
--- a/mail-client/mutt/mutt-1.5.8-r2.ebuild
+++ b/mail-client/mutt/mutt-1.5.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.8-r2.ebuild,v 1.9 2005/08/06 23:33:39 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.8-r2.ebuild,v 1.10 2005/08/11 22:57:29 agriffis Exp $
inherit eutils flag-o-matic
IUSE="cjk ssl nls slang crypt imap mbox nntp sasl buffysize vanilla"
@@ -44,6 +44,15 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="alpha amd64 hppa ia64 mips ppc ~ppc-macos ppc64 sparc x86"
+pkg_setup() {
+ if ! use imap; then
+ echo
+ einfo "NOTE: The USE variable 'imap' is not in your USE flags."
+ einfo "For imap support in mutt, you will need to restart the build with USE=imap"
+ echo
+ fi
+}
+
src_unpack() {
unpack ${P}i.tar.gz && cd ${S} || die "unpack failed"
if ! use vanilla; then
@@ -147,3 +156,10 @@ src_install() {
dodoc BEWARE COPYRIGHT ChangeLog NEWS OPS* PATCHES README* TODO VERSION
}
+
+pkg_postinst() {
+ echo
+ einfo "For information about using mutt, please refer to:"
+ einfo " http://www.gentoo.org/doc/en/guide-to-mutt.xml"
+ echo
+}
diff --git a/mail-client/mutt/mutt-1.5.9.ebuild b/mail-client/mutt/mutt-1.5.9.ebuild
index 4b4992b81e08..9c1b5a39b7dd 100644
--- a/mail-client/mutt/mutt-1.5.9.ebuild
+++ b/mail-client/mutt/mutt-1.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.9.ebuild,v 1.1 2005/08/11 22:48:36 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.9.ebuild,v 1.2 2005/08/11 22:57:29 agriffis Exp $
inherit eutils flag-o-matic
@@ -52,6 +52,15 @@ DEPEND="${RDEPEND}
net-mail/mailbase
!vanilla? ( sys-devel/automake sys-devel/autoconf )"
+pkg_setup() {
+ if ! use imap; then
+ echo
+ einfo "NOTE: The USE variable 'imap' is not in your USE flags."
+ einfo "For imap support in mutt, you will need to restart the build with USE=imap"
+ echo
+ fi
+}
+
src_unpack() {
unpack ${P}i.tar.gz && cd ${S} || die "unpack failed"
@@ -178,3 +187,10 @@ src_install() {
dodoc BEWARE COPYRIGHT ChangeLog NEWS OPS* PATCHES README* TODO VERSION
}
+
+pkg_postinst() {
+ echo
+ einfo "For information about using mutt, please refer to:"
+ einfo " http://www.gentoo.org/doc/en/guide-to-mutt.xml"
+ echo
+}