summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-17 02:02:21 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-17 02:02:21 +0000
commit4f22e6adc207c0fd62abe947037a9385a0611dc0 (patch)
tree36225930db6d41a9765e13688c303e3a352353b1
parent+move net-misc/entropy net-p2p/entropy_rsa (diff)
downloadgentoo-2-4f22e6adc207c0fd62abe947037a9385a0611dc0.tar.gz
gentoo-2-4f22e6adc207c0fd62abe947037a9385a0611dc0.tar.bz2
gentoo-2-4f22e6adc207c0fd62abe947037a9385a0611dc0.zip
initial import #100780
(Portage version: 2.0.53_rc5)
-rw-r--r--net-p2p/entropy_rsa/ChangeLog8
-rw-r--r--net-p2p/entropy_rsa/Manifest4
-rw-r--r--net-p2p/entropy_rsa/entropy_rsa-0.9.1.439.ebuild75
-rw-r--r--net-p2p/entropy_rsa/files/digest-entropy_rsa-0.9.1.4391
-rw-r--r--net-p2p/entropy_rsa/files/entropy_rsa.rc22
-rw-r--r--net-p2p/entropy_rsa/files/mysql.conf31
-rw-r--r--net-p2p/entropy_rsa/metadata.xml5
7 files changed, 146 insertions, 0 deletions
diff --git a/net-p2p/entropy_rsa/ChangeLog b/net-p2p/entropy_rsa/ChangeLog
new file mode 100644
index 000000000000..46c6e4c8ed98
--- /dev/null
+++ b/net-p2p/entropy_rsa/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-p2p/entropy_rsa
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/entropy_rsa/ChangeLog,v 1.1 2005/10/17 02:02:21 vapier Exp $
+
+*entropy_rsa-0.9.1.439 (16 Oct 2005)
+
+ 16 Oct 2005; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by michael #100780.
diff --git a/net-p2p/entropy_rsa/Manifest b/net-p2p/entropy_rsa/Manifest
new file mode 100644
index 000000000000..ec8bd47385c6
--- /dev/null
+++ b/net-p2p/entropy_rsa/Manifest
@@ -0,0 +1,4 @@
+MD5 e1bcf606cf83ff143346f599b73df67c entropy_rsa-0.9.1.439.ebuild 2097
+MD5 97484eec85be95860492aeda9fb1d633 files/digest-entropy_rsa-0.9.1.439 70
+MD5 d0ecf8cbc811fc5ce5f33c6731551358 files/entropy_rsa.rc 582
+MD5 de97a7df967b27a3afab0d9ba6022469 files/mysql.conf 1189
diff --git a/net-p2p/entropy_rsa/entropy_rsa-0.9.1.439.ebuild b/net-p2p/entropy_rsa/entropy_rsa-0.9.1.439.ebuild
new file mode 100644
index 000000000000..6f1c262da472
--- /dev/null
+++ b/net-p2p/entropy_rsa/entropy_rsa-0.9.1.439.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/entropy_rsa/entropy_rsa-0.9.1.439.ebuild,v 1.1 2005/10/17 02:02:21 vapier Exp $
+
+inherit eutils
+
+MY_PV_BUILD=${PV##*.}
+MY_PV=${PV%.*}
+DESCRIPTION="A p2p-node to share your files, infos, philosophy ... anonymously"
+HOMEPAGE="http://entropy.stop1984.com/"
+SRC_URI="http://entropy.stop1984.com/files/entropy_rsa-${MY_PV}-${MY_PV_BUILD}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mysql"
+
+DEPEND="mysql? ( dev-db/mysql )"
+RDEPEND="${DEPEND}
+ app-admin/sudo"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+pkg_setup() {
+ enewgroup entropy
+ enewuser entropy -1 /bin/false /var/entropy entropy
+}
+
+src_compile() {
+ [[ $(gcc-major-version) == "4" ]] && die "Sorry, entropy must be compiled with gcc-3.x"
+
+ local myconf=""
+ use mysql \
+ && myconf="--with-mysql=/usr" \
+ || myconf="--with-tree"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ dobin entropy_rsa monoopt storechg || die
+ dodoc README TODO CODINGRULES entropy_rsa.conf-dist seed.txt-dist
+ dohtml ENTROPY.html
+ use mysql && dodoc README.MySQL
+
+ newinitd "${FILESDIR}"/entropy_rsa.rc entropy_rsa
+ local STORE_TYPE="tree"
+ use mysql && STORE_TYPE="mysql"
+ echo "ENTROPY_USER=entropy" > entropy_rsa.conf.d
+ echo "STORE_TYPE=${STORE_TYPE}" >> entropy_rsa.conf.d
+ newconfd entropy_rsa.conf.d entropy_rsa
+
+ diropts -o entropy -g entropy
+ insopts -o entropy -g entropy -m0644
+ dodir /var/entropy/{de,chat,node,store,tmp}
+ insinto /var/entropy
+ doins -r de node chat || die
+
+ # setup config file
+ sed -e "3,$ s:#::g" seed.txt-dist > seed.txt
+ sed \
+ -e "s:seednodes=seed.txt:seednodes=/var/entropy/seed.txt:g" \
+ -e "s:logfile=./entropy_rsa.log:logfile=/var/entropy/entropy_rsa.log:g" \
+ -e "s:storepath=store:storepath=/var/entropy/store:g" \
+ -e "s:temppath=tmp:temppath=/var/entropy/tmp:g" \
+ -e "s:runpath=:runpath=/var/entropy/:g" \
+ entropy_rsa.conf-dist > entropy_rsa.conf
+ use mysql && cat "${FILESDIR}"/mysql.conf >> entropy_rsa.conf
+ insinto /etc
+ doins entropy_rsa.conf
+ dosym /etc/entropy_rsa.conf /var/entropy/entropy_rsa.conf
+
+ insinto /var/entropy
+ doins ${CONFIG} seed.txt
+}
diff --git a/net-p2p/entropy_rsa/files/digest-entropy_rsa-0.9.1.439 b/net-p2p/entropy_rsa/files/digest-entropy_rsa-0.9.1.439
new file mode 100644
index 000000000000..660919364cb9
--- /dev/null
+++ b/net-p2p/entropy_rsa/files/digest-entropy_rsa-0.9.1.439
@@ -0,0 +1 @@
+MD5 1ffb94f461c61a248bc9b5e7c01aa15c entropy_rsa-0.9.1-439.tgz 880745
diff --git a/net-p2p/entropy_rsa/files/entropy_rsa.rc b/net-p2p/entropy_rsa/files/entropy_rsa.rc
new file mode 100644
index 000000000000..536ae69dc1d8
--- /dev/null
+++ b/net-p2p/entropy_rsa/files/entropy_rsa.rc
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+ [[ ${STORE_TYPE} == "mysql" ]] && need mysql
+}
+
+start() {
+ ebegin "Starting ENTROPY/RSA"
+ cd ~entropy || return 1
+ sudo -u ${ENTROPY_USER} entropy_rsa
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ENTROPY/RSA"
+ cd ~entropy || return 1
+ entropy_rsa --kill
+ eend $?
+}
diff --git a/net-p2p/entropy_rsa/files/mysql.conf b/net-p2p/entropy_rsa/files/mysql.conf
new file mode 100644
index 000000000000..ae17a6828f2e
--- /dev/null
+++ b/net-p2p/entropy_rsa/files/mysql.conf
@@ -0,0 +1,31 @@
+
+# All the options below this point are for the MySQL data store. If you
+# are not using MySQL, you can stop now.
+# The login name you use to access MySQL. This user needs to have
+# permission to create, drop, and optimize tables, and to insert, select,
+# update, and delete data in MySQL.
+mysql_user=myname
+
+# The password for mysql_user
+mysql_pass=mypass
+
+# The name of the database Entropy will store its tables in. You have to
+# create this database before running Entropy.
+mysql_db=entropy_rsa
+
+# If your database server is not running on the same computer as your
+# Entropy node, enter the database server's hostname here.
+mysql_host=localhost
+
+# The port number MySQL is using. If you are using the default MySQL
+# port, you can just leave this set to zero.
+mysql_port=0
+
+# Set this flag to non-zero (or true, or yes) to enable optimization of
+# your MySQL tables during node start-up. Optimizing will take some time.
+mysql_optimize=false
+
+# Set the maximum size for a single mysql table, i.e. the storeXX tables
+# If you change this, be sure to have stordepth= set to the number of
+# tables you had before (check with mysql). The default table size is 1GB.
+mysql_tablesize=1GB
diff --git a/net-p2p/entropy_rsa/metadata.xml b/net-p2p/entropy_rsa/metadata.xml
new file mode 100644
index 000000000000..f93cc7071612
--- /dev/null
+++ b/net-p2p/entropy_rsa/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>p2p</herd>
+</pkgmetadata>