summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Bainbridge <chrb@gentoo.org>2005-01-02 17:26:33 +0000
committerChris Bainbridge <chrb@gentoo.org>2005-01-02 17:26:33 +0000
commit3a293fb5224dbc78a8435615810282549ffce2fa (patch)
tree4adcf3b081d252a94c1eb278cabdfecbbe2a2265
parenti18n-ru fix (Manifest recommit) (diff)
downloadgentoo-2-3a293fb5224dbc78a8435615810282549ffce2fa.tar.gz
gentoo-2-3a293fb5224dbc78a8435615810282549ffce2fa.tar.bz2
gentoo-2-3a293fb5224dbc78a8435615810282549ffce2fa.zip
fix bug #63221
-rw-r--r--sci-biology/ecell/ChangeLog9
-rw-r--r--sci-biology/ecell/Manifest4
-rw-r--r--sci-biology/ecell/ecell-3.1.102-r1.ebuild44
-rw-r--r--sci-biology/ecell/ecell-3.1.102.ebuild4
-rw-r--r--sci-biology/ecell/files/digest-ecell-3.1.102-r11
5 files changed, 57 insertions, 5 deletions
diff --git a/sci-biology/ecell/ChangeLog b/sci-biology/ecell/ChangeLog
index b06da523894d..e5cd04159e8a 100644
--- a/sci-biology/ecell/ChangeLog
+++ b/sci-biology/ecell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/ecell
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/ecell/ChangeLog,v 1.3 2004/12/28 20:27:57 ribosome Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/ecell/ChangeLog,v 1.4 2005/01/02 17:26:33 chrb Exp $
+
+ 02 Jan 2005; Chris Bainbridge <chrb@gentoo.org> :
+ Replaced gtk flag with gnome flag, since gui is actually a gnome app not
+ gtk, despite what configure claims. Should fix bug #63221 (thanks to daniel
+ robert hyduke for original patch)
28 Dec 2004; Olivier Fisette <ribosome@gentoo.org> ecell-3.1.102.ebuild:
Dependency update: dev-libs/gsl -> sci-libs/gsl.
diff --git a/sci-biology/ecell/Manifest b/sci-biology/ecell/Manifest
index edb51af747c6..5598c8db0745 100644
--- a/sci-biology/ecell/Manifest
+++ b/sci-biology/ecell/Manifest
@@ -1,4 +1,6 @@
-MD5 f4f7e5db84b5861e3672841bcf6788c0 ecell-3.1.102.ebuild 780
MD5 9b892c88ca72d6c344737c9787feaaa8 ChangeLog 878
MD5 155da428f344189ed3afe853bdd0a233 metadata.xml 354
+MD5 f4f7e5db84b5861e3672841bcf6788c0 ecell-3.1.102.ebuild 780
+MD5 239fdd6a126eeade4ff04d7b43534e05 ecell-3.1.102-r1.ebuild 1098
MD5 8f591a6f5e0c8c4c1389b02612d7c6df files/digest-ecell-3.1.102 66
+MD5 8f591a6f5e0c8c4c1389b02612d7c6df files/digest-ecell-3.1.102-r1 66
diff --git a/sci-biology/ecell/ecell-3.1.102-r1.ebuild b/sci-biology/ecell/ecell-3.1.102-r1.ebuild
new file mode 100644
index 000000000000..cc4b000ad629
--- /dev/null
+++ b/sci-biology/ecell/ecell-3.1.102-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/ecell/ecell-3.1.102-r1.ebuild,v 1.1 2005/01/02 17:26:33 chrb Exp $
+
+inherit eutils
+
+DESCRIPTION="Software suite for modelling biological cells"
+HOMEPAGE="http://ecell.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ecell/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc gnome"
+
+DEPEND="dev-libs/boost
+ dev-lang/python
+ dev-python/numeric
+ sci-libs/gsl
+ dev-python/empy
+ gnome? ( gnome-base/libglade
+ >=dev-python/pygtk-2
+ dev-python/gnome-python
+ x11-libs/gtk+extra
+ dev-python/python-gtkextra)
+ doc? ( media-gfx/graphviz
+ app-doc/doxygen
+ docbook-sgml-utils)"
+
+src_compile() {
+ local myconf
+ use gnome || myconf="--disable-gtk"
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake doc || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ einstall || die
+ if use doc; then
+ dohtml doc/refman/html || die "HTML docs missing"
+ fi
+}
diff --git a/sci-biology/ecell/ecell-3.1.102.ebuild b/sci-biology/ecell/ecell-3.1.102.ebuild
index 8ce8d174b6e3..dbabeb80a8b3 100644
--- a/sci-biology/ecell/ecell-3.1.102.ebuild
+++ b/sci-biology/ecell/ecell-3.1.102.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/ecell/ecell-3.1.102.ebuild,v 1.2 2004/12/28 20:27:57 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/ecell/ecell-3.1.102.ebuild,v 1.3 2005/01/02 17:26:33 chrb Exp $
inherit eutils
diff --git a/sci-biology/ecell/files/digest-ecell-3.1.102-r1 b/sci-biology/ecell/files/digest-ecell-3.1.102-r1
new file mode 100644
index 000000000000..d2b07bae10a3
--- /dev/null
+++ b/sci-biology/ecell/files/digest-ecell-3.1.102-r1
@@ -0,0 +1 @@
+MD5 3772cbc6c6516e3ab005ba12e8c6a903 ecell-3.1.102.tar.gz 3204291