summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2005-01-31 11:33:29 +0000
committerHanno Böck <hanno@gentoo.org>2005-01-31 11:33:29 +0000
commit35aae7516b1b6d03632a8e6475835dc16fe9e8ab (patch)
treeb40d4dc3d6ecde578eefbe4a07fe4bc8996ec2ea
parentx86 -* keywords (diff)
downloadgentoo-2-35aae7516b1b6d03632a8e6475835dc16fe9e8ab.tar.gz
gentoo-2-35aae7516b1b6d03632a8e6475835dc16fe9e8ab.tar.bz2
gentoo-2-35aae7516b1b6d03632a8e6475835dc16fe9e8ab.zip
gwenhywfar version bump
(Portage version: 2.0.51-r15)
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/files/digest-gwenhywfar-1.7.21
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-1.7.2.ebuild41
3 files changed, 48 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index 5fb5c4872e0e..47d802769980 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.7 2005/01/23 01:39:23 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.8 2005/01/31 11:33:29 hanno Exp $
+
+*gwenhywfar-1.7.2 (31 Jan 2005)
+
+ 31 Jan 2005; Hanno Boeck <hanno@gentoo.org> +gwenhywfar-1.7.2.ebuild:
+ Version bump.
*gwenhywfar-1.6.0 (23 Jan 2005)
diff --git a/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.7.2 b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.7.2
new file mode 100644
index 000000000000..06c4dab598a0
--- /dev/null
+++ b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.7.2
@@ -0,0 +1 @@
+MD5 a09a39dbfb375f682e641cf0811f8dba gwenhywfar-1.7.2.tar.gz 977076
diff --git a/sys-libs/gwenhywfar/gwenhywfar-1.7.2.ebuild b/sys-libs/gwenhywfar/gwenhywfar-1.7.2.ebuild
new file mode 100644
index 000000000000..b1d955894332
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-1.7.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-1.7.2.ebuild,v 1.1 2005/01/31 11:33:29 hanno Exp $
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~sparc ~alpha ~ppc"
+
+IUSE="debug ssl doc"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ sys-libs/ncurses
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ if use doc; then
+ APIDOC="--with-docpath=/usr/share/doc/${P}/apidoc"
+ fi
+ econf \
+ `use_enable ssl` \
+ `use_enable debug` \
+ `use_enable doc full-doc` \
+ ${APIDOC} || die "configure failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake srcdoc || die "Building the api-doc failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README* AUTHORS ABOUT-NLS COPYING ChangeLog INSTALL TODO
+ if use doc; then
+ make DESTDIR=${D} install-srcdoc || die "Installing the API-Doc failed"
+ fi
+}