summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2008-11-21 22:38:56 +0000
committerKeri Harris <keri@gentoo.org>2008-11-21 22:38:56 +0000
commit2d643ac2b186252c5893abe5d2b14e0097cfe0a6 (patch)
treed8dc390e8fad0159e20dc22b6d964d1661565308
parentFixed homepage. (diff)
downloadgentoo-2-2d643ac2b186252c5893abe5d2b14e0097cfe0a6.tar.gz
gentoo-2-2d643ac2b186252c5893abe5d2b14e0097cfe0a6.tar.bz2
gentoo-2-2d643ac2b186252c5893abe5d2b14e0097cfe0a6.zip
Block dev-libs/mpatrol. Bug #247070.
(Portage version: 2.1.4.5)
-rw-r--r--dev-lang/mercury/ChangeLog7
-rw-r--r--dev-lang/mercury/mercury-0.12.2-r3.ebuild5
-rw-r--r--dev-lang/mercury/mercury-0.12.2-r4.ebuild5
-rw-r--r--dev-lang/mercury/mercury-0.13.1-r1.ebuild5
-rw-r--r--dev-lang/mercury/mercury-0.13.1-r2.ebuild5
-rw-r--r--dev-lang/mercury/mercury-0.13.1.ebuild5
6 files changed, 21 insertions, 11 deletions
diff --git a/dev-lang/mercury/ChangeLog b/dev-lang/mercury/ChangeLog
index 508de266c645..8690cf6e017d 100644
--- a/dev-lang/mercury/ChangeLog
+++ b/dev-lang/mercury/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/mercury
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/ChangeLog,v 1.85 2008/09/23 06:17:35 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/ChangeLog,v 1.86 2008/11/21 22:38:56 keri Exp $
+
+ 21 Nov 2008; <keri@gentoo.org> mercury-0.12.2-r3.ebuild,
+ mercury-0.12.2-r4.ebuild, mercury-0.13.1.ebuild, mercury-0.13.1-r1.ebuild,
+ mercury-0.13.1-r2.ebuild:
+ Block dev-libs/mpatrol. Bug #247070.
23 Sep 2008; <keri@gentoo.org> +files/mercury-0.13.1-rebuild-mslice.patch,
mercury-0.13.1-r2.ebuild:
diff --git a/dev-lang/mercury/mercury-0.12.2-r3.ebuild b/dev-lang/mercury/mercury-0.12.2-r3.ebuild
index 9560b7d9df72..fc7eb06ad0d1 100644
--- a/dev-lang/mercury/mercury-0.12.2-r3.ebuild
+++ b/dev-lang/mercury/mercury-0.12.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.12.2-r3.ebuild,v 1.16 2008/05/09 07:28:40 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.12.2-r3.ebuild,v 1.17 2008/11/21 22:38:56 keri Exp $
inherit eutils
@@ -17,7 +17,8 @@ KEYWORDS="~amd64 ppc ~sparc x86"
IUSE="debug minimal readline threads"
-DEPEND="readline? ( sys-libs/readline )"
+DEPEND="!dev-util/mpatrol
+ readline? ( sys-libs/readline )"
S="${WORKDIR}"/${MY_P}
TESTDIR="${WORKDIR}"/${PN}-tests-${PV}
diff --git a/dev-lang/mercury/mercury-0.12.2-r4.ebuild b/dev-lang/mercury/mercury-0.12.2-r4.ebuild
index 4c7f0c289aaa..acd551c1dedd 100644
--- a/dev-lang/mercury/mercury-0.12.2-r4.ebuild
+++ b/dev-lang/mercury/mercury-0.12.2-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.12.2-r4.ebuild,v 1.7 2008/05/09 07:28:40 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.12.2-r4.ebuild,v 1.8 2008/11/21 22:38:56 keri Exp $
inherit eutils
@@ -17,7 +17,8 @@ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="debug minimal readline threads"
-DEPEND="readline? ( sys-libs/readline )"
+DEPEND="!dev-libs/mpatrol
+ readline? ( sys-libs/readline )"
S="${WORKDIR}"/${MY_P}
TESTDIR="${WORKDIR}"/${PN}-tests-${PV}
diff --git a/dev-lang/mercury/mercury-0.13.1-r1.ebuild b/dev-lang/mercury/mercury-0.13.1-r1.ebuild
index 04bcea1a9140..69000865dca6 100644
--- a/dev-lang/mercury/mercury-0.13.1-r1.ebuild
+++ b/dev-lang/mercury/mercury-0.13.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.13.1-r1.ebuild,v 1.12 2008/05/09 07:28:40 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.13.1-r1.ebuild,v 1.13 2008/11/21 22:38:56 keri Exp $
inherit eutils flag-o-matic
@@ -17,7 +17,8 @@ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="debug minimal readline threads"
-DEPEND="readline? ( sys-libs/readline )"
+DEPEND="!dev-libs/mpatrol
+ readline? ( sys-libs/readline )"
S="${WORKDIR}"/${MY_P}
TESTDIR="${WORKDIR}"/${PN}-tests-${PV}
diff --git a/dev-lang/mercury/mercury-0.13.1-r2.ebuild b/dev-lang/mercury/mercury-0.13.1-r2.ebuild
index 8fd765d0f61f..5167026cfbfd 100644
--- a/dev-lang/mercury/mercury-0.13.1-r2.ebuild
+++ b/dev-lang/mercury/mercury-0.13.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.13.1-r2.ebuild,v 1.2 2008/09/23 06:17:35 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.13.1-r2.ebuild,v 1.3 2008/11/21 22:38:56 keri Exp $
inherit eutils flag-o-matic
@@ -17,7 +17,8 @@ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="debug minimal readline test threads"
-DEPEND="readline? ( sys-libs/readline )"
+DEPEND="!dev-libs/mpatrol
+ readline? ( sys-libs/readline )"
S="${WORKDIR}"/${MY_P}
TESTDIR="${WORKDIR}"/${PN}-tests-${PV}
diff --git a/dev-lang/mercury/mercury-0.13.1.ebuild b/dev-lang/mercury/mercury-0.13.1.ebuild
index ff69547b1faa..8b383569e529 100644
--- a/dev-lang/mercury/mercury-0.13.1.ebuild
+++ b/dev-lang/mercury/mercury-0.13.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.13.1.ebuild,v 1.3 2008/05/09 07:28:40 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-0.13.1.ebuild,v 1.4 2008/11/21 22:38:56 keri Exp $
inherit eutils
@@ -17,7 +17,8 @@ KEYWORDS="~ppc ~sparc ~x86"
IUSE="debug minimal readline threads"
-DEPEND="readline? ( sys-libs/readline )"
+DEPEND="!dev-libs/mpatrol
+ readline? ( sys-libs/readline )"
S="${WORKDIR}"/${MY_P}
TESTDIR="${WORKDIR}"/${PN}-tests-${PV}