summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-08-20 23:12:53 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-08-20 23:12:53 +0000
commit2aa32caaed68ebaad6eea40f0c40238f604dbe6d (patch)
treefb77ff032b213bab29eb9dd996b6f7875a1769b0
parentInitial commit, ebuild by Jaco Kroon. For bug #328513. (diff)
downloadgentoo-2-2aa32caaed68ebaad6eea40f0c40238f604dbe6d.tar.gz
gentoo-2-2aa32caaed68ebaad6eea40f0c40238f604dbe6d.tar.bz2
gentoo-2-2aa32caaed68ebaad6eea40f0c40238f604dbe6d.zip
Initial commit, ebuild by Jaco Kroon. For bug #328513.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--net-misc/asterisk-moh-opsound/ChangeLog10
-rw-r--r--net-misc/asterisk-moh-opsound/asterisk-moh-opsound-2.03.ebuild52
-rw-r--r--net-misc/asterisk-moh-opsound/metadata.xml20
3 files changed, 82 insertions, 0 deletions
diff --git a/net-misc/asterisk-moh-opsound/ChangeLog b/net-misc/asterisk-moh-opsound/ChangeLog
new file mode 100644
index 000000000000..4f9517183f47
--- /dev/null
+++ b/net-misc/asterisk-moh-opsound/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/asterisk-moh-opsound
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-moh-opsound/ChangeLog,v 1.1 2010/08/20 23:12:53 chainsaw Exp $
+
+*asterisk-moh-opsound-2.03 (20 Aug 2010)
+
+ 20 Aug 2010; <chainsaw@gentoo.org> +asterisk-moh-opsound-2.03.ebuild,
+ +metadata.xml:
+ Initial commit, ebuild by Jaco Kroon. For bug #328513.
+
diff --git a/net-misc/asterisk-moh-opsound/asterisk-moh-opsound-2.03.ebuild b/net-misc/asterisk-moh-opsound/asterisk-moh-opsound-2.03.ebuild
new file mode 100644
index 000000000000..00d2dfa1f7a2
--- /dev/null
+++ b/net-misc/asterisk-moh-opsound/asterisk-moh-opsound-2.03.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-moh-opsound/asterisk-moh-opsound-2.03.ebuild,v 1.1 2010/08/20 23:12:53 chainsaw Exp $
+
+EAPI="2"
+
+DESCRIPTION="asterisk moh music"
+HOMEPAGE="http://www.asterisk.org/"
+CODECS="alaw g722 g729 +gsm siren7 siren14 sln16 ulaw wav"
+
+SRC_URI=""
+for c in ${CODECS}; do
+ SRC_URI+=" ${c#+}? ( http://downloads.asterisk.org/pub/telephony/sounds/releases/${PN}-${c#+}-${PV}.tar.gz )"
+done
+
+IUSE="${CODECS}"
+LICENSE="CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=net-misc/asterisk-1.6.2.11-r1"
+
+src_install() {
+ local c
+
+ for c in ${CODECS}; do
+ if use ${c#+}; then
+ for pf in CREDITS LICENSE CHANGES; do
+ dodoc "$pf-$PN-${c#+}"
+ rm "$pf-$PN-${c#+}"
+ done
+ fi
+ done
+
+ diropts -m 0770 -o asterisk -g asterisk
+ insopts -m 0660 -o asterisk -g asterisk
+
+ dodir /var/lib/asterisk/moh
+ insinto /var/lib/asterisk/moh
+ doins -r .
+
+}
+
+pkg_postinst() {
+ local c has_once_codec=
+
+ for c in ${CODECS}; do
+ use ${c#+} && has_one_codec=1
+ done
+
+ [ -n "${has_one_codec}" ] || ewarn "You have none of the codec use flags (${CODECS}) set. You need to have at least one set in order for this package to be useful."
+}
diff --git a/net-misc/asterisk-moh-opsound/metadata.xml b/net-misc/asterisk-moh-opsound/metadata.xml
new file mode 100644
index 000000000000..639419ffc299
--- /dev/null
+++ b/net-misc/asterisk-moh-opsound/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>voip</herd>
+ <maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+ <use>
+ <flag name="alaw">Install the sounds files for the alaw codec.</flag>
+ <flag name="g722">Install the sounds files for the g722 codec.</flag>
+ <flag name="g729">Install the sounds files for the g729 codec.</flag>
+ <flag name="gsm">Install the sounds files for the +gsm codec.</flag>
+ <flag name="siren7">Install the sounds files for the siren7 codec.</flag>
+ <flag name="siren14">Install the sounds files for the siren14 codec.</flag>
+ <flag name="sln16">Install the sounds files for the sln16 codec.</flag>
+ <flag name="ulaw">Install the sounds files for the ulaw codec.</flag>
+ <flag name="wav">Install the sounds files for the wav codec.</flag>
+ </use>
+</pkgmetadata>