summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-09-24 02:40:17 +0000
committerTravis Tilley <lv@gentoo.org>2004-09-24 02:40:17 +0000
commit228c7228485a465e7b7ea0b3488afacea1fb5cce (patch)
treef452ff0528c29d8727048c0d47b28fa2c3415e3c
parentUnmasking gnustep-apps/affiche-0.6.0 as it works now (diff)
downloadgentoo-2-228c7228485a465e7b7ea0b3488afacea1fb5cce.tar.gz
gentoo-2-228c7228485a465e7b7ea0b3488afacea1fb5cce.tar.bz2
gentoo-2-228c7228485a465e7b7ea0b3488afacea1fb5cce.zip
make CONF_LIBDIR aware again to fix a sandbox violation. lets hope nobody reverts the change this time.
-rw-r--r--sys-devel/gdb/ChangeLog6
-rw-r--r--sys-devel/gdb/gdb-6.2.1.ebuild7
2 files changed, 10 insertions, 3 deletions
diff --git a/sys-devel/gdb/ChangeLog b/sys-devel/gdb/ChangeLog
index 69fab6738c0d..e4313c417440 100644
--- a/sys-devel/gdb/ChangeLog
+++ b/sys-devel/gdb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gdb
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.54 2004/09/22 23:36:25 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.55 2004/09/24 02:40:17 lv Exp $
+
+ 23 Sep 2004; Travis Tilley <lv@gentoo.org> gdb-6.2.1.ebuild:
+ make CONF_LIBDIR aware again to fix a sandbox violation. lets hope nobody
+ reverts the change this time.
*gdb-6.2.1 (23 Sep 2004)
diff --git a/sys-devel/gdb/gdb-6.2.1.ebuild b/sys-devel/gdb/gdb-6.2.1.ebuild
index 1d183057531b..87449f4b9e1b 100644
--- a/sys-devel/gdb/gdb-6.2.1.ebuild
+++ b/sys-devel/gdb/gdb-6.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.2.1.ebuild,v 1.1 2004/09/22 23:36:25 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.2.1.ebuild,v 1.2 2004/09/24 02:40:17 lv Exp $
inherit flag-o-matic eutils
@@ -25,7 +25,9 @@ src_unpack() {
src_compile() {
replace-flags -O? -O2
- econf `use_enable nls` || die
+ econf \
+ `use_enable nls` \
+ --libdir=/usr/$(get_libdir) || die
make || die
}
@@ -33,6 +35,7 @@ src_install() {
make \
prefix=${D}/usr \
mandir=${D}/usr/share/man \
+ libdir=${D}/usr/$(get_libdir) \
infodir=${D}/usr/share/info \
install || die