summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2009-10-29 18:09:59 +0000
committerDominik Kapusta <ayoy@gentoo.org>2009-10-29 18:09:59 +0000
commit1e428c29b5d0a9962ef55b35c555dc2e386db2cc (patch)
tree85c902d023af53215ade2a712f222805a33e663d
parentAdding a patch to fix regression in event loop. Thanks to scarabeus@g.o for p... (diff)
downloadgentoo-2-1e428c29b5d0a9962ef55b35c555dc2e386db2cc.tar.gz
gentoo-2-1e428c29b5d0a9962ef55b35c555dc2e386db2cc.tar.bz2
gentoo-2-1e428c29b5d0a9962ef55b35c555dc2e386db2cc.zip
Adding a patch to fix regression in event loop. Thanks to scarabeus@g.o for pointing this out
(Portage version: 2.2_rc46/cvs/Linux x86_64)
-rw-r--r--x11-libs/qt-dbus/ChangeLog9
-rw-r--r--x11-libs/qt-dbus/files/qt-4.5.3-glib-event-loop.patch11
-rw-r--r--x11-libs/qt-dbus/qt-dbus-4.5.3-r1.ebuild41
3 files changed, 60 insertions, 1 deletions
diff --git a/x11-libs/qt-dbus/ChangeLog b/x11-libs/qt-dbus/ChangeLog
index c44bf3d3bf7b..9b063b0dd06a 100644
--- a/x11-libs/qt-dbus/ChangeLog
+++ b/x11-libs/qt-dbus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/qt-dbus
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/ChangeLog,v 1.42 2009/10/29 11:22:44 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/ChangeLog,v 1.43 2009/10/29 18:09:59 ayoy Exp $
+
+*qt-dbus-4.5.3-r1 (29 Oct 2009)
+
+ 29 Oct 2009; Dominik Kapusta <ayoy@gentoo.org> +qt-dbus-4.5.3-r1.ebuild,
+ +files/qt-4.5.3-glib-event-loop.patch:
+ Adding a patch to fix regression in event loop. Thanks to scarabeus@g.o
+ for pointing this out
29 Oct 2009; Christian Faulhammer <fauli@gentoo.org> qt-dbus-4.5.3.ebuild:
stable x86, bug 290922
diff --git a/x11-libs/qt-dbus/files/qt-4.5.3-glib-event-loop.patch b/x11-libs/qt-dbus/files/qt-4.5.3-glib-event-loop.patch
new file mode 100644
index 000000000000..580f027a5471
--- /dev/null
+++ b/x11-libs/qt-dbus/files/qt-4.5.3-glib-event-loop.patch
@@ -0,0 +1,11 @@
+diff -up qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp.than qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp
+--- qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp.than 2009-10-29 16:15:58.000000000 +0100
++++ qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp 2009-10-29 16:16:22.000000000 +0100
+@@ -263,7 +263,6 @@ QEventDispatcherGlibPrivate::QEventDispa
+ (void) new (&timerSource->timerList) QTimerInfoList();
+ timerSource->processEventsFlags = QEventLoop::AllEvents;
+ g_source_set_can_recurse(&timerSource->source, true);
+- g_source_set_priority(&timerSource->source, G_PRIORITY_DEFAULT_IDLE);
+ g_source_attach(&timerSource->source, mainContext);
+ }
+
diff --git a/x11-libs/qt-dbus/qt-dbus-4.5.3-r1.ebuild b/x11-libs/qt-dbus/qt-dbus-4.5.3-r1.ebuild
new file mode 100644
index 000000000000..7a3dad7a4831
--- /dev/null
+++ b/x11-libs/qt-dbus/qt-dbus-4.5.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/qt-dbus-4.5.3-r1.ebuild,v 1.1 2009/10/29 18:09:59 ayoy Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The DBus module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=]
+ >=sys-apps/dbus-1.0.2"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/dbus
+tools/qdbus/qdbus
+tools/qdbus/qdbusxml2cpp
+tools/qdbus/qdbuscpp2xml"
+QCONFIG_ADD="dbus dbus-linked"
+QCONFIG_DEFINE="QT_DBUS"
+
+#FIXME: Check if these are still needed with the header package
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/QtCore
+include/QtDBus
+include/QtXml
+src/corelib
+src/xml"
+
+PATCHES=(
+ "${FILESDIR}/qt-4.5-nolibx11.diff"
+ "${FILESDIR}/qt-4.5.3-glib-event-loop.patch"
+)
+
+src_configure() {
+ myconf="${myconf} -dbus-linked"
+ qt4-build_src_configure
+}