summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-30 11:45:28 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-30 11:45:28 +0000
commit1b93952bfe1fc251cf3a9fbb40c01278d94135d5 (patch)
treeecc3abd47d33b1539495eb69079f47af178266e8
parentamd64/x86 stable, bug #290164 (diff)
downloadgentoo-2-1b93952bfe1fc251cf3a9fbb40c01278d94135d5.tar.gz
gentoo-2-1b93952bfe1fc251cf3a9fbb40c01278d94135d5.tar.bz2
gentoo-2-1b93952bfe1fc251cf3a9fbb40c01278d94135d5.zip
Small updates.
-rw-r--r--dev-lang/python/python-2.4.6.ebuild20
-rw-r--r--dev-lang/python/python-2.5.4-r3.ebuild21
-rw-r--r--dev-lang/python/python-3.1.1-r1.ebuild13
3 files changed, 18 insertions, 36 deletions
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index 2233c5978a5f..61b95222a825 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.22 2009/10/17 05:03:53 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.23 2009/10/30 11:45:28 arfrever Exp $
EAPI="1"
@@ -134,13 +134,6 @@ src_configure() {
myconf="--with-cxx=no"
fi
- # Super-secret switch. Don't use this unless you know what you're
- # doing. Enabling UCS2 support will break your existing python
- # modules
- use ucs2 \
- && myconf+=" --enable-unicode=ucs2" \
- || myconf+=" --enable-unicode=ucs4"
-
filter-flags -malign-double
[[ "${ARCH}" == "alpha" ]] && append-flags -fPIC
@@ -173,6 +166,7 @@ src_configure() {
--enable-shared \
$(use_enable ipv6) \
$(use_with threads) \
+ $(use ucs2 && echo "--enable-unicode=ucs2" || echo "--enable-unicode=ucs4") \
--infodir='${prefix}'/share/info \
--mandir='${prefix}'/share/man \
--with-libc='' \
@@ -267,20 +261,20 @@ pkg_preinst() {
}
eselect_python_update() {
- local ignored_python_slots
- [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots="--ignore 3.0 --ignore 3.1 --ignore 3.2"
+ local ignored_python_slots_options=
+ [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots_options="--ignore 3.0 --ignore 3.1 --ignore 3.2"
# Create python2 symlink.
eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 > /dev/null
- eselect python update ${ignored_python_slots}
+ eselect python update ${ignored_python_slots_options}
}
pkg_postinst() {
eselect_python_update
+ # Python 2.4 partially doesn't respect $(get_libdir).
python_mod_optimize -x "(site-packages|test)" /usr/lib/python${PYVER}
- [[ "$(get_libdir)" != "lib" ]] && python_mod_optimize -x "(site-packages|test)" /usr/$(get_libdir)/python${PYVER}
if [[ "${python_updater_warning}" == "1" ]]; then
ewarn
@@ -298,6 +292,6 @@ pkg_postinst() {
pkg_postrm() {
eselect_python_update
+ # Python 2.4 partially doesn't respect $(get_libdir).
python_mod_cleanup /usr/lib/python${PYVER}
- [[ "$(get_libdir)" != "lib" ]] && python_mod_cleanup /usr/$(get_libdir)/python${PYVER}
}
diff --git a/dev-lang/python/python-2.5.4-r3.ebuild b/dev-lang/python/python-2.5.4-r3.ebuild
index 02e70fdd13ab..b19f081bff8c 100644
--- a/dev-lang/python/python-2.5.4-r3.ebuild
+++ b/dev-lang/python/python-2.5.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.25 2009/10/17 05:09:30 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.26 2009/10/30 11:45:28 arfrever Exp $
EAPI="1"
@@ -135,15 +135,6 @@ src_configure() {
export OPT="${CFLAGS}"
- local myconf
-
- # Super-secret switch. Don't use this unless you know what you're
- # doing. Enabling UCS2 support will break your existing python
- # modules
- use ucs2 \
- && myconf+=" --enable-unicode=ucs2" \
- || myconf+=" --enable-unicode=ucs4"
-
filter-flags -malign-double
[[ "${ARCH}" == "alpha" ]] && append-flags -fPIC
@@ -180,10 +171,10 @@ src_configure() {
--enable-shared \
$(use_enable ipv6) \
$(use_with threads) \
+ $(use ucs2 && echo "--enable-unicode=ucs2" || echo "--enable-unicode=ucs4") \
--infodir='${prefix}'/share/info \
--mandir='${prefix}'/share/man \
- --with-libc='' \
- ${myconf}
+ --with-libc=''
}
src_compile() {
@@ -273,13 +264,13 @@ pkg_preinst() {
}
eselect_python_update() {
- local ignored_python_slots
- [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots="--ignore 3.0 --ignore 3.1 --ignore 3.2"
+ local ignored_python_slots_options=
+ [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots_options="--ignore 3.0 --ignore 3.1 --ignore 3.2"
# Create python2 symlink.
eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 > /dev/null
- eselect python update ${ignored_python_slots}
+ eselect python update ${ignored_python_slots_options}
}
pkg_postinst() {
diff --git a/dev-lang/python/python-3.1.1-r1.ebuild b/dev-lang/python/python-3.1.1-r1.ebuild
index 53dba79ca4ff..56f0a1c37ba2 100644
--- a/dev-lang/python/python-3.1.1-r1.ebuild
+++ b/dev-lang/python/python-3.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.15 2009/10/24 14:35:31 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.16 2009/10/30 11:45:28 arfrever Exp $
EAPI="2"
@@ -250,21 +250,18 @@ src_install() {
pkg_preinst() {
if has_version "<${CATEGORY}/${PN}-${SLOT}" && ! has_version ">=${CATEGORY}/${PN}-${SLOT}_alpha"; then
- # Delete this check after global switching to Python 3.
- if [[ "$(eselect python show)" == "python3."* ]]; then
- python_updater_warning="1"
- fi
+ python_updater_warning="1"
fi
}
eselect_python_update() {
- local ignored_python_slots
- [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots="--ignore 3.0 --ignore 3.1 --ignore 3.2"
+ local ignored_python_slots_options=
+ [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots_options="--ignore 3.0 --ignore 3.1 --ignore 3.2"
# Create python3 symlink.
eselect python update > /dev/null
- eselect python update ${ignored_python_slots}
+ eselect python update ${ignored_python_slots_options}
}
pkg_postinst() {