summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-04-22 17:46:50 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-04-22 17:46:50 +0000
commit1a95b013fc72a0a264d3ff71059b89030c362698 (patch)
treec7e920306082d8cde40ff3c5afde7692636b823e
parentRefactor ebuild to use python functions correctly. Fixes bug #313989 (diff)
downloadgentoo-2-1a95b013fc72a0a264d3ff71059b89030c362698.tar.gz
gentoo-2-1a95b013fc72a0a264d3ff71059b89030c362698.tar.bz2
gentoo-2-1a95b013fc72a0a264d3ff71059b89030c362698.zip
Refactor ebuild to use python functions correctly. Fixes bug #312665
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--kde-misc/kanyremote/kanyremote-5.10.ebuild9
-rw-r--r--kde-misc/kanyremote/kanyremote-5.11.ebuild9
2 files changed, 14 insertions, 4 deletions
diff --git a/kde-misc/kanyremote/kanyremote-5.10.ebuild b/kde-misc/kanyremote/kanyremote-5.10.ebuild
index 9bbc0d1729d5..982b6089ac3d 100644
--- a/kde-misc/kanyremote/kanyremote-5.10.ebuild
+++ b/kde-misc/kanyremote/kanyremote-5.10.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-5.10.ebuild,v 1.3 2010/04/19 14:18:15 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-5.10.ebuild,v 1.4 2010/04/22 17:46:50 hwoarang Exp $
EAPI="2"
+PYTHON_DEPEND="2"
-inherit base
+inherit python base
DESCRIPTION="KDE frontend to Anyremote"
HOMEPAGE="http://anyremote.sourceforge.net/"
@@ -21,6 +22,10 @@ DEPEND=">=app-mobilephone/anyremote-4.4[bluetooth?]
bluetooth? ( dev-python/pybluez )"
RDEPEND="${DEPEND}"
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_prepare() {
#fix documentation directory wrt bug #316087
sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am
diff --git a/kde-misc/kanyremote/kanyremote-5.11.ebuild b/kde-misc/kanyremote/kanyremote-5.11.ebuild
index eb3fae93ce4f..4d760425f8b3 100644
--- a/kde-misc/kanyremote/kanyremote-5.11.ebuild
+++ b/kde-misc/kanyremote/kanyremote-5.11.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-5.11.ebuild,v 1.3 2010/04/19 14:18:15 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-5.11.ebuild,v 1.4 2010/04/22 17:46:50 hwoarang Exp $
EAPI="2"
-inherit autotools base
+PYTHON_DEPEND="2"
+inherit autotools python base
DESCRIPTION="KDE frontend to Anyremote"
HOMEPAGE="http://anyremote.sourceforge.net/"
@@ -21,6 +22,10 @@ DEPEND=">=app-mobilephone/anyremote-4.4[bluetooth?]
bluetooth? ( dev-python/pybluez )"
RDEPEND="${DEPEND}"
+pkg_setup () {
+ python_set_active_version 2
+}
+
src_prepare() {
#fix documentation directory wrt bug #316087
sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am