summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-19 18:32:31 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-19 18:32:31 +0000
commit15c5d9f62371538803eeef7c620faae221bcf0c6 (patch)
treee6eaf6efa89c56c0e330c75269e85977096efc77
parentAdd ~ia64, wrt bug #428356 (diff)
downloadgentoo-2-15c5d9f62371538803eeef7c620faae221bcf0c6.tar.gz
gentoo-2-15c5d9f62371538803eeef7c620faae221bcf0c6.tar.bz2
gentoo-2-15c5d9f62371538803eeef7c620faae221bcf0c6.zip
Migrate to distutils-r1 and clean up.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
-rw-r--r--dev-python/pytz/ChangeLog9
-rw-r--r--dev-python/pytz/files/pytz-2009h-zoneinfo-noinstall.patch32
-rw-r--r--dev-python/pytz/pytz-2012h-r1.ebuild38
3 files changed, 77 insertions, 2 deletions
diff --git a/dev-python/pytz/ChangeLog b/dev-python/pytz/ChangeLog
index ff7b3f838e26..756440fff192 100644
--- a/dev-python/pytz/ChangeLog
+++ b/dev-python/pytz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pytz
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytz/ChangeLog,v 1.130 2012/11/03 00:58:24 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytz/ChangeLog,v 1.131 2012/12/19 18:32:31 mgorny Exp $
+
+*pytz-2012h-r1 (19 Dec 2012)
+
+ 19 Dec 2012; Michał Górny <mgorny@gentoo.org>
+ +files/pytz-2009h-zoneinfo-noinstall.patch, +pytz-2012h-r1.ebuild:
+ Migrate to distutils-r1 and clean up.
*pytz-2012h (03 Nov 2012)
@@ -481,4 +487,3 @@
24 Nov 2005; Marien Zwart <marienz@gentoo.org> +metadata.xml,
+pytz-2005m.ebuild:
New ebuild, based on an ebuild from André Malo <nd@perlig.de> (bug #111513)
-
diff --git a/dev-python/pytz/files/pytz-2009h-zoneinfo-noinstall.patch b/dev-python/pytz/files/pytz-2009h-zoneinfo-noinstall.patch
new file mode 100644
index 000000000000..2e9709579883
--- /dev/null
+++ b/dev-python/pytz/files/pytz-2009h-zoneinfo-noinstall.patch
@@ -0,0 +1,32 @@
+From e43745593e4627de8027587cb3b4a465c93fa0b1 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Wed, 19 Dec 2012 19:22:29 +0100
+Subject: [PATCH] Do not install zoneinfo files.
+
+---
+ setup.py | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index c8152d5..8f13279 100644
+--- a/setup.py
++++ b/setup.py
+@@ -13,15 +13,8 @@ me = 'Stuart Bishop'
+ memail = 'stuart@stuartbishop.net'
+ packages = ['pytz']
+ resources = ['zone.tab', 'locales/pytz.pot']
+-for dirpath, dirnames, filenames in os.walk(os.path.join('pytz', 'zoneinfo')):
+- # remove the 'pytz' part of the path
+- basepath = dirpath.split(os.path.sep, 1)[1]
+- resources.extend([os.path.join(basepath, filename)
+- for filename in filenames])
+ package_data = {'pytz': resources}
+
+-assert len(resources) > 10, 'zoneinfo files not found!'
+-
+ setup (
+ name='pytz',
+ version=pytz.VERSION,
+--
+1.8.0.2
+
diff --git a/dev-python/pytz/pytz-2012h-r1.ebuild b/dev-python/pytz/pytz-2012h-r1.ebuild
new file mode 100644
index 000000000000..b990f091732b
--- /dev/null
+++ b/dev-python/pytz/pytz-2012h-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytz/pytz-2012h-r1.ebuild,v 1.1 2012/12/19 18:32:31 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9} )
+inherit distutils-r1
+
+DESCRIPTION="World timezone definitions for Python"
+HOMEPAGE="http://pypi.python.org/pypi/pytz http://pytz.sourceforge.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=sys-libs/timezone-data-${PV}"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES.txt )
+
+PATCHES=(
+ # Use timezone-data zoneinfo.
+ "${FILESDIR}/${PN}-2009j-zoneinfo.patch"
+ # ...and do not install a copy of it.
+ "${FILESDIR}/${PN}-2009h-zoneinfo-noinstall.patch"
+)
+
+python_test() {
+ "${PYTHON}" pytz/tests/test_tzinfo.py
+}
+
+python_install() {
+ distutils-r1_python_install
+}