summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2005-03-04 03:16:13 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2005-03-04 03:16:13 +0000
commit144eb52e04399302426e979f045d17cda9b306b6 (patch)
treeda20cde7639c12ad0250aa44c47986df2a83ae6b
parentNew version incorporating some KDE patches (diff)
downloadgentoo-2-144eb52e04399302426e979f045d17cda9b306b6.tar.gz
gentoo-2-144eb52e04399302426e979f045d17cda9b306b6.tar.bz2
gentoo-2-144eb52e04399302426e979f045d17cda9b306b6.zip
Fixed the installation problem of the libraries. Hey, my first commit
(Portage version: 2.0.51-r15)
-rw-r--r--dev-haskell/hsshellscript/ChangeLog12
-rw-r--r--dev-haskell/hsshellscript/Manifest6
-rw-r--r--dev-haskell/hsshellscript/hsshellscript-2.1.0.ebuild13
-rw-r--r--dev-haskell/hsshellscript/metadata.xml2
4 files changed, 23 insertions, 10 deletions
diff --git a/dev-haskell/hsshellscript/ChangeLog b/dev-haskell/hsshellscript/ChangeLog
index a60bb84842fc..6c738cd31283 100644
--- a/dev-haskell/hsshellscript/ChangeLog
+++ b/dev-haskell/hsshellscript/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-haskell/hsshellscript
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/ChangeLog,v 1.1 2005/01/24 14:20:03 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/ChangeLog,v 1.2 2005/03/04 03:16:13 araujo Exp $
+
+ 03 Mar 2005; Luis F. Araujo <araujo@gentoo.org> metadata.xml,
+ hsshellscript-2.1.0.ebuild:
+ Fixed the installation problem of the libraries
+
+*hsshellscript-2.1.0 (03 Mar 2005)
+
+ 03 Mar 2005; Luis F. Araujo <araujo@gentoo.org> metadata.xml,
+ hsshellscript-2.1.0.ebuild:
+ Fixed the installation problem of the libraries
24 Jan 2005; Andres Loeh <kosmikus@gentoo.org> :
Initial import (bug #79170).
diff --git a/dev-haskell/hsshellscript/Manifest b/dev-haskell/hsshellscript/Manifest
index 1b9e4954e746..bf6d19b7d798 100644
--- a/dev-haskell/hsshellscript/Manifest
+++ b/dev-haskell/hsshellscript/Manifest
@@ -1,4 +1,4 @@
-MD5 77779c6cbf9f0dd96ab1597ee40d1f92 ChangeLog 308
-MD5 a769ecfcd1cdd2d40986627df7dfb249 metadata.xml 224
-MD5 52c57b7134dc5facee0b0b478fc0d5f1 hsshellscript-2.1.0.ebuild 1136
+MD5 e7c3593c62adafc8f60b991df8af8c41 ChangeLog 489
+MD5 63e640716107efc3b8f4e7e7aa240fb3 hsshellscript-2.1.0.ebuild 1137
+MD5 3f6e26f4a44d1b5c6ff6380d989e6af6 metadata.xml 222
MD5 29b043a8133ca29f855bd09a4ce05033 files/digest-hsshellscript-2.1.0 71
diff --git a/dev-haskell/hsshellscript/hsshellscript-2.1.0.ebuild b/dev-haskell/hsshellscript/hsshellscript-2.1.0.ebuild
index 5853c5f21c50..9d1f1dc33d90 100644
--- a/dev-haskell/hsshellscript/hsshellscript-2.1.0.ebuild
+++ b/dev-haskell/hsshellscript/hsshellscript-2.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/hsshellscript-2.1.0.ebuild,v 1.1 2005/01/24 14:20:03 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/hsshellscript-2.1.0.ebuild,v 1.2 2005/03/04 03:16:13 araujo Exp $
inherit base eutils ghc-package
@@ -21,8 +21,7 @@ RDEPEND=">=virtual/ghc-6.2"
src_unpack() {
base_src_unpack
cd ${S}
- sed -i -e "s:ghc-pkg\(.*\)--auto-ghci-libs:$(ghc-getghcpkg) -f ${S}/$(ghc-localpkgconf) \1:" \
- Makefile
+ sed -i -e "/ghc-pkg/d" Makefile
}
src_compile() {
@@ -34,7 +33,11 @@ src_compile() {
}
src_install() {
- ghc-setup-pkg
+ sed -i "s:\${DEST_LIB}:$(ghc-libdir):" \
+ ${S}/lib/hsshellscript.pkg
+ sed -i "s:\${DEST_IMPORTS}:$(ghc-libdir)/imports:" \
+ ${S}/lib/hsshellscript.pkg
+ ghc-setup-pkg ${S}/lib/hsshellscript.pkg
make install \
DESTDIR="${D}" \
DEST_LIB="$(ghc-libdir)" \
@@ -42,5 +45,5 @@ src_install() {
DEST_DOC="/usr/share/doc/${PF}" \
|| die "make failed"
ghc-install-pkg
- ghc-makeghcilib "${D}/$(ghc-libdir)/libhsshellscript.a"
+ ghc-makeghcilib ${D}/$(ghc-libdir)/libhsshellscript.a
}
diff --git a/dev-haskell/hsshellscript/metadata.xml b/dev-haskell/hsshellscript/metadata.xml
index a53a18c06081..eac910e799d2 100644
--- a/dev-haskell/hsshellscript/metadata.xml
+++ b/dev-haskell/hsshellscript/metadata.xml
@@ -3,6 +3,6 @@
<pkgmetadata>
<herd>haskell</herd>
<maintainer>
- <email>kosmikus@gentoo.org</email>
+ <email>araujo@gentoo.org</email>
</maintainer>
</pkgmetadata>