summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-23 18:49:35 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-23 18:49:35 +0000
commit1231113dc7d50432aacac816a6074c987466fb3e (patch)
treed82d732119d96fadf759b2e468ab0f9fd2545cd8
parentTweak xen warning a bit #263434 by Jeremy Olexa. (diff)
downloadgentoo-2-1231113dc7d50432aacac816a6074c987466fb3e.tar.gz
gentoo-2-1231113dc7d50432aacac816a6074c987466fb3e.tar.bz2
gentoo-2-1231113dc7d50432aacac816a6074c987466fb3e.zip
old
-rw-r--r--sys-libs/timezone-data/timezone-data-2008i.ebuild106
-rw-r--r--sys-libs/timezone-data/timezone-data-2009a.ebuild106
2 files changed, 0 insertions, 212 deletions
diff --git a/sys-libs/timezone-data/timezone-data-2008i.ebuild b/sys-libs/timezone-data/timezone-data-2008i.ebuild
deleted file mode 100644
index db4060e3dca5..000000000000
--- a/sys-libs/timezone-data/timezone-data-2008i.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2008i.ebuild,v 1.8 2008/12/22 04:50:25 vapier Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-code_ver=${PV%i}h
-data_ver=${PV}
-DESCRIPTION="Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump)"
-HOMEPAGE="ftp://elsie.nci.nih.gov/pub/"
-SRC_URI="ftp://elsie.nci.nih.gov/pub/tzdata${data_ver}.tar.gz
- ftp://elsie.nci.nih.gov/pub/tzcode${code_ver}.tar.gz
- mirror://gentoo/tzdata${data_ver}.tar.gz
- mirror://gentoo/tzcode${code_ver}.tar.gz"
-
-LICENSE="BSD public-domain"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="nls elibc_FreeBSD elibc_glibc"
-
-DEPEND=""
-
-S=${WORKDIR}
-
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}"/${PN}-2008h-makefile.patch
- tc-is-cross-compiler && cp -pR "${S}" "${S}"-native
-}
-
-src_compile() {
- local LDLIBS
- tc-export CC
- use elibc_FreeBSD && append-flags -DSTD_INSPIRED #138251
- if use nls ; then
- use elibc_glibc || LDLIBS="${LDLIBS} -lintl" #154181
- export NLS=1
- else
- export NLS=0
- fi
- # Makefile uses LBLIBS for the libs (which defaults to LDFLAGS)
- # But it also uses LFLAGS where it expects the real LDFLAGS
- emake \
- LDLIBS="${LDLIBS}" \
- || die "emake failed"
- if tc-is-cross-compiler ; then
- emake -C "${S}"-native \
- CC=$(tc-getBUILD_CC) \
- CFLAGS="${BUILD_CFLAGS}" \
- LDFLAGS="${BUILD_LDFLAGS}" \
- LDLIBS="${LDLIBS}" \
- zic || die
- fi
-}
-
-src_install() {
- local zic=""
- tc-is-cross-compiler && zic="zic=${S}-native/zic"
- emake install ${zic} DESTDIR="${D}" || die
- rm -rf "${D}"/usr/share/zoneinfo-leaps
- dodoc README Theory
- dohtml *.htm *.jpg
-}
-
-pkg_config() {
- # make sure the /etc/localtime file does not get stale #127899
- local tz src
-
- if has_version '<sys-apps/baselayout-2' ; then
- src="/etc/conf.d/clock"
- tz=$(unset TIMEZONE ; source "${ROOT}"/etc/conf.d/clock ; echo ${TIMEZONE-FOOKABLOIE})
- else
- src="/etc/timezone"
- if [[ -e ${ROOT}/etc/timezone ]] ; then
- tz=$(<"${ROOT}"/etc/timezone)
- else
- tz="FOOKABLOIE"
- fi
- fi
- [[ -z ${tz} ]] && return 0
-
- if [[ ${tz} == "FOOKABLOIE" ]] ; then
- elog "You do not have TIMEZONE set in ${src}."
-
- if [[ ! -e ${ROOT}/etc/localtime ]] ; then
- cp -f "${ROOT}"/usr/share/zoneinfo/Factory "${ROOT}"/etc/localtime
- elog "Setting /etc/localtime to Factory."
- else
- elog "Skipping auto-update of /etc/localtime."
- fi
- return 0
- fi
-
- if [[ ! -e ${ROOT}/usr/share/zoneinfo/${tz} ]] ; then
- elog "You have an invalid TIMEZONE setting in ${src}"
- elog "Your /etc/localtime has been reset to Factory; enjoy!"
- tz="Factory"
- fi
- einfo "Updating /etc/localtime with /usr/share/zoneinfo/${tz}"
- [[ -L ${ROOT}/etc/localtime ]] && rm -f "${ROOT}"/etc/localtime
- cp -f "${ROOT}"/usr/share/zoneinfo/"${tz}" "${ROOT}"/etc/localtime
-}
-
-pkg_postinst() {
- pkg_config
-}
diff --git a/sys-libs/timezone-data/timezone-data-2009a.ebuild b/sys-libs/timezone-data/timezone-data-2009a.ebuild
deleted file mode 100644
index dd41a7a92829..000000000000
--- a/sys-libs/timezone-data/timezone-data-2009a.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2009a.ebuild,v 1.1 2009/01/21 16:37:32 vapier Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-code_ver=${PV}
-data_ver=${PV}
-DESCRIPTION="Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump)"
-HOMEPAGE="ftp://elsie.nci.nih.gov/pub/"
-SRC_URI="ftp://elsie.nci.nih.gov/pub/tzdata${data_ver}.tar.gz
- ftp://elsie.nci.nih.gov/pub/tzcode${code_ver}.tar.gz
- mirror://gentoo/tzdata${data_ver}.tar.gz
- mirror://gentoo/tzcode${code_ver}.tar.gz"
-
-LICENSE="BSD public-domain"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="nls elibc_FreeBSD elibc_glibc"
-
-DEPEND=""
-
-S=${WORKDIR}
-
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}"/${PN}-2008h-makefile.patch
- tc-is-cross-compiler && cp -pR "${S}" "${S}"-native
-}
-
-src_compile() {
- local LDLIBS
- tc-export CC
- use elibc_FreeBSD && append-flags -DSTD_INSPIRED #138251
- if use nls ; then
- use elibc_glibc || LDLIBS="${LDLIBS} -lintl" #154181
- export NLS=1
- else
- export NLS=0
- fi
- # Makefile uses LBLIBS for the libs (which defaults to LDFLAGS)
- # But it also uses LFLAGS where it expects the real LDFLAGS
- emake \
- LDLIBS="${LDLIBS}" \
- || die "emake failed"
- if tc-is-cross-compiler ; then
- emake -C "${S}"-native \
- CC=$(tc-getBUILD_CC) \
- CFLAGS="${BUILD_CFLAGS}" \
- LDFLAGS="${BUILD_LDFLAGS}" \
- LDLIBS="${LDLIBS}" \
- zic || die
- fi
-}
-
-src_install() {
- local zic=""
- tc-is-cross-compiler && zic="zic=${S}-native/zic"
- emake install ${zic} DESTDIR="${D}" || die
- rm -rf "${D}"/usr/share/zoneinfo-leaps
- dodoc README Theory
- dohtml *.htm *.jpg
-}
-
-pkg_config() {
- # make sure the /etc/localtime file does not get stale #127899
- local tz src
-
- if has_version '<sys-apps/baselayout-2' ; then
- src="/etc/conf.d/clock"
- tz=$(unset TIMEZONE ; source "${ROOT}"/etc/conf.d/clock ; echo ${TIMEZONE-FOOKABLOIE})
- else
- src="/etc/timezone"
- if [[ -e ${ROOT}/etc/timezone ]] ; then
- tz=$(<"${ROOT}"/etc/timezone)
- else
- tz="FOOKABLOIE"
- fi
- fi
- [[ -z ${tz} ]] && return 0
-
- if [[ ${tz} == "FOOKABLOIE" ]] ; then
- elog "You do not have TIMEZONE set in ${src}."
-
- if [[ ! -e ${ROOT}/etc/localtime ]] ; then
- cp -f "${ROOT}"/usr/share/zoneinfo/Factory "${ROOT}"/etc/localtime
- elog "Setting /etc/localtime to Factory."
- else
- elog "Skipping auto-update of /etc/localtime."
- fi
- return 0
- fi
-
- if [[ ! -e ${ROOT}/usr/share/zoneinfo/${tz} ]] ; then
- elog "You have an invalid TIMEZONE setting in ${src}"
- elog "Your /etc/localtime has been reset to Factory; enjoy!"
- tz="Factory"
- fi
- einfo "Updating /etc/localtime with /usr/share/zoneinfo/${tz}"
- [[ -L ${ROOT}/etc/localtime ]] && rm -f "${ROOT}"/etc/localtime
- cp -f "${ROOT}"/usr/share/zoneinfo/"${tz}" "${ROOT}"/etc/localtime
-}
-
-pkg_postinst() {
- pkg_config
-}